api_target_minimum_api_error

API Target ou Minimun API Error

Opa pessoal

Tudo bem?

Como mencionei, esse fim de semana tive uma palestra na PUC e passamos por um problema não muito legal, e muitas pessoas passaram por ele em casa novamente.

Ao executar um App no simulador padrão que havia sido criado, o erro “Target device has an API level of 10,
but this application has a minimum API level of 15” aparecia, impossibilitando que o aplicativo fosse executado no emulador selecionado.

Depois de alguns minutos apanhando dos computadores, conseguimos identificar o problema, o emulador que havia sido criado com a API errada, como a própria mensagem dizia.

A solução era criar um emulador novo, mas antes seria necessário instalar as API’s das versões do android desejada utilizando o SDK Manager.

Nos posts de instalação – Parte 1 e Parte 2 – mostro como fazer a instalação das API’s

Vamos nos concentrar em criar o emulador novo agora

1) Abra o AVD (ANDROID VIRTUAL DEVICE) MANAGER, clique na aba Device Definition e escolha um dos aparelhos que deseja emular, vamos usar o Nexus 5

Selecionando Device para API 15

2) Clique em Create AVD, seleccione o processador (ARM) e uma Skin. Clique em OK e pronto. Emulador criado.

Vale lembrar que os emuladores são muito lentos comparador a uma aparelho. O ideal é, após iniciar ele, só fechar novamente quando não for utilizar.

É isso.

Dúvidas e sugestões?

Entre em contato aqui 😀

API Target ou Minimun API Error
5 (100%) 2 votos

Rafael Moura

Desenvolvedor .NET, mais de 5 anos de experiência, apaixonado por tecnologia, Xamarin Student Partner Regional Lead Central/South America, Xamarin Comunity Speaker, Xamarin Certified Mobile Developer e Windows Phone Developer.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

%d blogueiros gostam disto: